Can't pip install ookpy for the life of me!


#1

I have no idea why, I have the latest realease from python’s website, I tried reinstalling all my python stuff, and keep getting this error. ookpy-0.9.9.1-cp35-cp35m-win_amd64.whl is not a supported wheel on this platform.

comand out put looks like this in admin command prompt:
\Downloads>pip install ookpy-0.9.9.1-cp35-cp35m-win_amd64.whl --user
ookpy-0.9.9.1-cp35-cp35m-win_amd64.whl is not a supported wheel on this platform.

pip --version
pip 9.0.1

python --version
Python 3.6.2

pip install ookpy
Could not find a version that satisfies the requirement ookpy (from versions: )
No matching distribution found for ookpy

pip installs for other things work like opencv. My processor is intel pentium cpu g3258 3.2ghz x64 based processor. I tryed to install with every availible .whl file but none worked. I dont know what to do… please help me.


#2

Hi!

Thanks for this feedback :slight_smile:
I assume you are trying to install Ookpy on the Windows operating system ?
As for now, we are a bit behind the official Python roadmap, and Harfang/Ookpy is available for Python 3.4 and 3.5 only.

Please know that we are working on an update, with countless of improvements, including the way Harfang is interfaced with Python.

In the meantime, could you consider using Python 3.5 ?


#3

Yes! Thanks for the reply. I will do this. When will the official 3.6 be released?


#4

I did that and it worked. :slight_smile:


#5

We have a couple of weeks of work to complete the Python interface (we completely rewrote the C++/Python binding from the ground up), then the Lua binding will come (still a couple of weeks), then we’ll have the build machine to update.

I would say 2 months of time, probably less.


#6

Well it took much longer than expected but its done at least!